3 Axis Mill Machining Tutorial
Alec Bowman
This tutorial will walk you through the process of generating machine code for the University of Idaho Mechanical
Engineering Department’s two CNC Mills. It start with a predefined part and ends with functioning G-code for both the
machines. The part is designed to introduce you to many different machining processes and the variations in those
processes in CATIA.
Please note that this code is designed to be machined into wax. Do not use the speeds, feeds, or tool stopovers
presented for any other material except wax.
The accompanying CATPart can be found in the same location as this tutorial.

I. Create the Stock
A. Open CATIA V5
B. Open the “Part Design” Workbench
C. Save your part in a new file
1. Select “File->Save”
2. Navigate to the a directory of your choice
3. Create a new folder called “Car Mill Demo” then open it
4. Call your part “Stock”
5. Hit “Save”
D. Open a new sketch on the “xy plane”
E. Draw a rectangle with the bottom left corner at the origin
1. Make the rectangle 4.3 inches wide and 2.3 inches tall
► These dimensions are dictated by the actual dimensions of your stock. You can change these later
and CATIA will update the machining operations appropriately. This will be discussed later in this
tutorial.

F. Exit the sketch
G. Pad the sketch to “Length” of 1.4 inches
H. Change the block properties to make it red and transparent
1. Right click “Part Body” in the design tree
2. Select the “Graphic” tab
3. In the color drop down, select red
4. Move the transparency slider to about 100
5. Hit “OK”

I. Change the part number
1. Right click “Part1” in the design tree
2. Select “Properties”
3. Select the “Product” tab
4. Change the part number field to read “Stock”
5. Hit “OK”
J. Save and close the part
II. Create Machining Assembly
A. Open the “Assembly Design” Workbench
B. Change the part number of the assembly to “Machining Assembly”
► Do this the same way you did for the stock
C. Add the stock to the assembly
1. Select “Existing Component” button
2. Select “Machining Assembly” in the Design Tree
3. Navigate to your saved “Stock.CATPart” and open it
D. Fix the stock
1. Select the “Fix” Constraint
2. Select the part to fix it
E. Add the “Car.CATPart” to the assembly
1. Select “Existing Component” button (You may have to reselect “Machining Assembly” from the design tree)
2. Navigate to the “Car.CATPart” associated with this tutorial
F. Positioning “Car” inside “Stock”
1. Constrain the Z direction
a) Select the “Offset Constraint”
b) Select the top face of “Stock”

c) Right click “Stock (Stock.1)” in the design tree and select “Hide/Show”

d) Select the flat surface of the tear drop shaped pocket on “Car”

e) Make the offset distance -0.3 inches
f) Right click “Stock (Stack.1)” in the design tree and select “Hide/Show”

2. Constrain Y direction
a) Select the “Offset Constraint”
b) Select the front face of “Stock”
c) Hide “Stock (Stock.1)” in the design tree
d) Select the axis of the back hole of “Car”

e) Set the Offset to -1.15 inches
► -1.15 is half the length of the stock. You can make this value whatever is appropriate to center the
part in the stock.
f) Unhide “Stock (Stock.1)” in the design tree

g) Repeat steps a) through f) for the front hole of “Car”

3. Constrain X direction
a) Select the “Offset Constraint”
b) Select the back face of “Stock”
c) Hide “Stock (Stock.1)” in the design tree
d) Select the axis of the circular pocket of “Car”

e) Set the offset to -2.3
► This value is an arbitrary value that visually aligns “Car” in the center of “Stock”. This value was
found through trial and error
f) Unhide “Stock (Stock.1)” in the design tree

G. Use “Save Management” to save the entire assembly
1. Go to “File->Save Management…”
2. With “Machining Assembly” selected, hit “Save As…”
3. Save “Machining Assembly” in the same directory as “Stock”
4. Back in the “Save Management” pane, select “Propagate directory” then hit “OK”
III. Set up the Machining Workbench
A. With “Machining Assembly” selected in the design tree, select “Start->Machining->Advance Machining” to open
the Machining Workbench
B. Double click “Part Operation.1” in the design tree to open the “Part Operation” dialog box
C. Select the “Machine” button
to open the “Machine Editor” dialog box.
D. Select “OK”
► You do not have to make any changes in this dialog box. Just by opening it, you define the machine
to be a three axis mill. You will use this dialog box more when you select what machine you will use
in the shop.
E. Select the “Reference machining axis system” button
to define the machining origin of your part
F. Define the your machining origin
1. Select the red dot in the dialog box to set the origin location

2. Select the top, left corner of the stock

3. In the dialog box, select the “x” axis

4. Select the top, front line of the stock

5. Select “OK” in the “Direction X” dialog box
6. Hit “OK” again
G. Define stock
1. Select the “Stock” button
2. Select “Stock” from the workspace
3. Double click somewhere in the workspace not on the part to return to the dialog box
H. Define part
1. Select the “Design part for simulation” button
2. Expand “Machining Assembly (Machining Assembly.1)” in the design tree
3. Right click “Stock (Stock.1)” and hide the stock
► The stock will remain hidden for the rest of this toutorial
4. Select “Car” in the workspace
5. Double click somewhere in the workspace not on the part to return to the dialog box

6. Hit “OK”
7. Right click “Constraints” under “Machining Assembly (Machining Assembly.1)” to hide them
IV. Define Machining Operations
A. Define a “Roughing” operation
1. Select “Manufacturing Program.1” from the design tree
2. Select the “Roughing” button

3. Select the red region called “Part”

4.
5.
6.
7.

Select “Car” in the workspace
Double click somewhere in the workspace not on the part to return to the dialog box
Select the salmon colored region called “Bottom”
Select the bottom of “Car”

8. Your image should look like this:

► You only have to define regions that are red. The other regions are optional. They are used to
refine how CATIA handles your part when generating tool paths.
9. Select the “Machining Strategy” tab
a) Under the “Machining” tab:
(1) Change “Tool path style:” to “Spiral”

(2) Change “Machining Tolerance:” to 0.001 inches
b) Under the “Radial” tab:
(1) Change “Tool diameter ratio:” to 40
c) Under the “Axial” tab:
(1) Change “Maximum cut depth:” to 0.5 inches
10. Select the “Tool Data” tab
a) Change “Name” to “T1 0.5 End Mill”
b) Make sure “Ball-end tool” is deselected
c) Select the “More>>” button
d) Use the following values:

e) In the “Technology” tab, Change “Number of flutes:” to 2
11. Select the “Speeds and Rates” tab
a) Make your values match these:

12. Select the “Macro Data” tab
a) Under “Macro Management” select “Automatic” (you should already have this selected)
(1) Select “Optimize retract”
(2) Change “Mode:” to “Helix”
b) Under “Macro Management” select “Pre-motions”
(1) Select the “Add Axial motion” button
(2) Double click the line that appears
(a) Change distance to 0.75 inches
(b) Hit “OK”
c) Under “Macro Management” select “Post-motions”
(1) repeat all steps under b)
13. Click the “Tool Path Replay” button in the bottom right of the dialog box
14. Preview the machining operation
a) Select the “Rewind” button
b) Select the “Forward replay” button
► This will play the tool path. It will probably go too fast to be of much use. There is a slider below
the play controls, however, it is already set to the slowest speed.
c) Under the dropdown of replay mode, select “Point by Point replay of tool”

d) Select the “Rewind” button
e) Select the “Forward replay” button
► Note that in the “Point by Point” mode, the tool only progresses one step at a time. You can
repeatedly click the “Forward replay” button through the entire operation. You can also change the
number of steps per click with the number below the controls.
f) Click “OK”
15. Click “OK” to finish off the roughing operation.
► In the design tree, notice that there “Roughing.1” was created. The word “(Computed)” also appears
after the operation. This means that CATIA has actually generated the motions for this operation. If
you had not selected the “Tool Path Replay” button, it would not have been computed. This means
that if you ever change any part of the tool path, you must replay the tool path in order for the path
to be recomputed. If not, “(Computed)” will no longer show in the design tree and the path will NOT
be updated.
16. Save your process using “File->Save Management”. Call it “Car Process”
B. Define a “Profile” operation
1. Select “Roughing.1 (Computed)” in the design tree

► Before you define a new machining operation, you have to decide where you want it. By selecting
“Roughing.1 (Computed)” you are telling CATIA you want the next operation to be placed directly
after “Roughing.1 (Computed)”
2.
3.
4.
5.

Select the “Profile Contouring” button
Click the words “Bottom: Hard” This changes the text to “Bottom: Soft” and also changes the picture
Select the red square in the picture to define the bottom of the part
Select the bottom surface of “Car”
a) Once you select the bottom surface, CATIA reopens the “Profile Contouring.1” dialog box. It also
automatically selected the profile needed for the contour. Note that the contour area of the picture
turned green. Select this green area to see what was selected. You should have something that looks
like this:

► Note that there is an orange line around the bottom of the part. Also note that there is an orange
arrow pointing away from the part. This is saying that the tool should go along the outside of the
line and not the inside.
b) Double click somewhere in the workspace not on the part to return to the dialog box
6. Select the “Machining Strategy” tab
► CATIA will automatically try to populate all the fields in the operation dialog boxes based on what
you selected in the preceding operation. This means that there is less to define in each of the tabs.
a) Under the “Stepover” tab:
(1) Change “Distance between paths:” to 0.5 inches
7. Select the “Tool Data” tab
a) You cannot change anything in this tab because you are using the same tool as the last operation. This is
fine for this operation.
► We will change the tool for the next operation
8. Select the “Speeds and Rates” tab
a) Deselect “Automatic compute from tooling Feeds and Speeds” under “Feedrate”
b) Change “Finishing:” to 8 inches per minute
c) Deselect “Automatic compute from tooling Feeds and Speeds” under “Spindle Speed”
d) Change “Quality:” to “Finish”

9. Select the “Macro Data” tab
a) Under “Macro Management” select “Approach”
(1) Right click “Approach” and select “Activate”
(2) Select “Add Horizontal motion” button
(3) Double click the number in the picture and change the “Distance” to 0.5 inches and hit “OK”
(4) Select “Add Axial motion” button
(5) Double click the number in the picture and change the “Distance” to 1 inches and hit “OK”
► If you make a mistake while defining a macro motion, you can use either the “Delete selected
motion” button,
, or the “Remove all motions” button,
.
b) Repeat all of step a) (including step a) itself) for “Retract”
10. Hit the “Tool Path Replay” button to calculate and view the tool path you created. When you are done, hit
“OK”
11. Hit “OK” to finish defining “Profile Contouring.1”
12. Save your process
C. Define a “Sweeping” operation
1. Make sure that “Profile Contouring.1 (Computed)” is selected
2. Select the “Sweeping” button
a) Right click the red “Part” region and select “Select faces …”
(1) Select the top curved face and all the top edge fillets

(2) Double click somewhere in the workspace not on the part to return to the dialog box
b) Double click “Offset on part” and change it to 0 inches
c) Double click “Offset on check” and change it to 0 inches

3. Select the “Machining Strategy” tab
a) Under the “Radial” tab:
(1) Change “Max. distance between pass:” to 0.035 inches
b) Under the “Axial” tab:
(1) Change “Maximum cut depth:” to 0.1 inches
4. Select the “Tool Data” tab
► We need to change to a different tool at this point. To do that, we will change the tool name. This
will automatically generate a tool change in the design tree
a) Change “Name” to “T2 5/16 Ball End Mill”
► Note that the “Tool number:” field changed to 2. It is very important to make sure that this number
is correct. If it is not, the CNC machine will not change tool offset.
b) Check the box for “Ball-end tool”
c) Click “More>>” to define the tool properties as follows:

d) Under the “Technology” tab, change the “Number of flutes:” to 3
5. Select the “Speeds and Rates” tab
a) Deselect “Automatic compute from tooling Feeds and Speeds” under “Feedrate”
b) Change “Machining:” to 15 inches per minute
c) Deselect “Automatic compute from tooling Feeds and Speeds” under “Spindle Speed”
6. Select the “Macro Data” tab
a) Under “Macro Management” select “Approach”
(1) Change “Mode:” to “Built by user”
(2) Select the “Remove all motions” button,
(3) Select “Add Horizontal motion” button
(4) Double click the number in the picture and change the “Distance” to 0.25 inches and hit “OK”
(5) Select “Add Axial motion” button
(6) Double click the number in the picture and change the “Distance” to 1 inches and hit “OK”
b) Repeat step a) for “Retract”
c) Under “Macro Management” select “Clearance”, then right click “Clearance” and select “Deactivate”. Do
the same for “Between passes” (This will automatically deactivate Between passes Link”)
d) Under “Macro Management” select “Linking Retract”
(1) Change “Mode:” to “Along tool axis”
(2) Double click the number in the picture and change the “Distance” to 1 inches and hit “OK”
e) Repeat step d) for “Linking Approach”
7. Hit the “Tool Path Replay” button to calculate and view the tool path you created. When you are done, hit
“OK”
► You may need to change the “Replay mode” to “Continuous replay of tool path”
8. Hit “OK” to finish defining “Sweeping.1”
9. Save your process
D. Define a “Pocketing” operation
1. Make sure that “Sweeping.1 (Computed)” is selected
2. Select the “Pocketing” button
a) Click the word “Open Pocket” to change it to a “Closed Pocket”
b) Select the red wall of the image

(1) Select, line by line, the outer edge of the tear drop shaped pocket. When you are done, double click
to return to the dialog box.

3. Click the red bottom of the pocket in the image
a) Select the bottom of the pocket
► When we selected the bottom, it found several islands in the pocket. We want to ignore these, so
we need to deselect them.
b) Right click the green cube in the middle of the pocket and select “Remove all islands”
► In order to have multiple passes to remove material, we need to define a top of stock. This can be
done by creating a plane at the appropriate height, selecting a flat surface at the same height as the
top of stock, or, as in this case, select the actual top of stock.
4. Select the salmon colored top boundary of the pocket
a) Click the “Swap visible space” button
hidden.
b) Select the top of the stock

at the bottom of the screen to view all the items that are

c) Click the “Swap visible space” button again to return to the regular viewing mode

5. Your “Pocketing.1” dialog box should look like this:

6. Select the “Machining Strategy” tab
a) Under the “Axial” tab:
(1) Change “Number of levels:” to 2
b) Under the “Finishing” tab:
(1) Change “Mode:” to “Side finish last level”
(2) Change “Side finish thickness:” to 0.015 inches
7. Select the “Tool Data” tab
a) Change “Name” to “T3 1/8 End Mill”
► Make sure “Tool number:” now reads “3”
b) Uncheck the box for “Ball-end tool”
c) Click “More>>” to define the tool properties as follows:

d) Under the “Technology” tab, change the “Number of flutes:” to 4
8. Select the “Speeds and Rates” tab
a) Deselect “Automatic compute from tooling Feeds and Speeds” under “Feedrate”
b) Change “Finishing:” to 8 inches per minute
c) Deselect “Automatic compute from tooling Feeds and Speeds” under “Spindle Speed”
d) Under “Spindle Speed”, change “Machining:” to 2000 turns per minute
9. Select the “Macro Data” tab
a) Under “Macro Management” select “Approach”
(1) Add an axial “Approach” and “Retract” macro motion of 0.75 inches like in the other operations
10. Hit the “Tool Path Replay” button to calculate and view the tool path you created. When you are done, hit
“OK”
11. Hit “OK” to finish defining “Pocketing.1”
12. Save your process
E. Define a second “Pocketing” operation
1. Make sure that “Pocketing.1 (Computed)” is selected
2. Select the “Pocketing” button
a) Click the word “Open Pocket” to change it to a “Closed Pocket”
b) Select the bottom of the pocket in the image

(1) Select the bottom of the large circular pocket inside the tear drop pocket
► Note that the edge was automatically selected
3. Select the “Machining Strategy” tab
► Once again, note that the data was populated using the same data as in the last pocketing
operation.
a) Under the “Axial” tab:
(1) Change “Number of levels:” to 1
4. You do not need to change anything in the “Tool Data” because you are using the same tool as in the last
pocket
5. Select the “Speeds and Rates” tab
a) Deselect “Automatic compute from tooling Feeds and Speeds” under “Feedrate”
b) Deselect “Automatic compute from tooling Feeds and Speeds” under “Spindle Speed”

6. Select the “Macro Data” tab
► Your macro motions where carried over from the last pocketing operation
7. Hit the “Tool Path Replay” button to calculate and view the tool path you created. When you are done, hit
“OK”
8. Hit “OK” to finish defining “Pocketing.2”
9. Save your process
F. Define a “Spot Drilling” operation
1. Make sure that “Pocketing.2 (Computed)” is selected

2. Select the “Spot Drilling” button under “Drilling”
a) Select the red V shaped line in the image
(1) Select the two small circles on “Car”

(2) Double click back into the dialog box
(3) Change the depth of the hole to 0.1 inches by double clicking

3. Select the “Machining Strategy” tab
a) Change the “Approach clearance (A):” to 0.15 inches
4. Select the “Tool Data” tab
► CATIA automatically created a new tool because you cannot spot drill with an end mill.
a) Click the “Center Drill” button
to load the tool profile of a center drill
b) Change “Name” to “T4 Center Drill”
c) You do not need to change any of the dimensions for this center drill
5. Select the “Speeds and Rates” tab
a) Change the data to match the image below:

6. Select the “Macro Data” tab
a) Define an axial approach and retract macro of 0.15 inches
7. Hit the “Tool Path Replay” button to calculate and view the tool path you created. When you are done, hit
“OK”
8. Hit “OK” to finish defining “Spot Drilling.1”
9. Save your process
G. Define a Peck Drilling operation
1. Make sure that “Spot Drilling.1 (Computed)” is selected

2. Select the “Drilling Deep Hole” button under “Drilling”
a) Select one of the red parallel lines in the image
(1) Select the same two holes as in the spot drilling
(2) Double click back to the dialog box
3. Select the “Machining Strategy” tab
a) Change “Depth mode:” to “By shoulder (Ds)”
b) Change “Max depth of cut (Dc):” to 0.05 inches
c) Change “Retract offset (Or):” to 0 inches
4. Select the “Tool Data” tab
a) Click the “Drill” button
to load the tool profile of a drill
b) Change “Name” to “T5 Drill 0.25”

c) Use the following values to create the tool:

► These values are intentionally incorrect. We will modify them later.
5. Select the “Speeds and Rates” tab
a) Deselect “Automatic compute from tooling Feeds and Speeds” under “Feedrate”
b) Deselect “Automatic compute from tooling Feeds and Speeds” under “Spindle Speed”
6. Select the “Macro Data” tab
a) Define an axial approach and retract macro of 0.15 inches
7. Hit the “Tool Path Replay” button to calculate and view the tool path you created. When you are done, hit
“OK”
8. Hit “OK” to finish defining “Drilling Deep Hole.1”
9. Save your process
V. View a simulation of your complete process
A. Right click “Manufacturing Program.1” and go to “Manufacturing Program.1 object” and select “Start Video
Simulation using Tool Path”
► You now have a block the same size as the stock you defined earlier. The controls are the same as in
the “Tool Path Replay”, except this time you will see the material removal
B. Hit the “Forward Replay” button to watch the part being machined
C. Rewind to the beginning of the operations
D. Click the “Video Options” button
1. Check “Stop at tool change”
► If you select “Stop” under “Collision detection:” the simulation will stop if it detects a collision
between the unmachined stock and the tool. You can use this to be sure that you have not defined
an operation retract inaccurately. If you do find an error, there are viewing options to help you
understand the error. These issues can usually be resolved by adding/changing macro motions.
2. Click “OK”
E. Click the “Forward Replay” button. The simulation stops at any tool changes. Click the button again to pass the
tool change
F. Click “OK” when you are satisfied with watching the simulation
VI. Modify Tools
► We need to modify the 0.25 inch drill that we defined as a 0.125 inch drill. You cannot do this in the
tool path definition window after you exit out of it. You have to modify the tool in the design tree.
A. Double click “Tool Change.5 T5 Drill 0.25” to open the tool definition dialog box

1. Use the following values to create the tool:

B. Hit “OK”
VII. Change Stock Size
A. Unhide “Stock (Stock.1)” in the design tree. (If you don’t see it, it should be under “ProductList”-> “Machining
Assembly (Machining Assembly.1)”
B. Expand “Stock (Stock.1)” and double click “Stock”
1. Open the sketch that defines “Pad.1” (you have to expand the design tree)
a) Change the 2.3 to 2.4 inches
b) Exit the sketch
C. Double click “Machining Assembly (Machining Assembly.1)” to modify the assembly
1. Unhide the “Constraints” in the design tree
2. Change both of the -1.15 offset constraints to -1.2 inches
3. Hit the “Update All” button
at the bottom of the screen to update the constraints
4. Rehide the “Constraints” and “Stock (Stock.1)” in the design tree
► We have modified both the size and position of the stock, making all the tool paths inaccurate. We
need to update them to make them accurate again.
D. Right click “Manufacturing Program.1” and go to “Manufacturing Program.1 object” and select “Compute Tool
Path”
1. Select “Forced compute” to update all the operations
2. Hit “OK”
3. Hit “OK” again when it is done computing
E. Run a video simulation as in V. to see the updated simulation
F. Use “Save Management” to save both your process and the stock
VIII. Setup in Preparation for Posting the Machine Code
A. Double click “Part Operation.1” to open the “Part Operation” dialog box
1. Under the “Position” tab:
a) Change tool change point:

2. Click the “Machine” button
a) Under the “Spindle” tab, change the “Home point” to be the same as the “Tool Change Point”
b) Under the “Numerical Control” tab, do the following:
(1) Change “Post Processor” to “UofI_Bridgeport.lib” or “UofI_HAAS.lib”

► This is where you have to make the decision which machine you want to use in the shop. Both work
equally well. Note that the Bridgeport has a smaller machining envelope. This tutorial is designed
to fit inside that envelope. I will use the Bridgeport
► You can change the machine whenever you want. You just have to repost the code for each
machine.
► If you ever find an error with one of the post processors, the company IMS is very good at fixing the
problem (as they wrote the post processor.) You have to give a detailed explanation of what the
problem is and what you want the solution to be. It is good to reference both the APTsource code
and the G code (See appendix for an explanation of what these are.) When you send them the
information, attach the post processor you use, the APTsource code, and the G code. You should
have an updated post processor that same day (assuming you get it to them in a reasonable amount
of time. They close at 5pm Central Time.) If you don’t have it that day, it will probably be in your
email before you wake up the following day. Let Russ know if you are submitting a request for a
modified post processor.
(2) Change “Post Processor Words table” to “IMS_v8.pptable”
(3) Change “NC data type” to “ISO”
c) Hit “OK”
3. Hit “OK” again
IX. Posting Code
A. Right click “Manufacturing Program.1” and go to “Manufacturing Program.1 object” and select “Generate NC
Output Internally”
1. Make sure “by program” is selected under “Resulting NC Data”
2. Under “Output File:” click
a) Navigate to the location you used to save your process
(1) Create a new folder called “Post” and open it.
► When you generate code, CATIA generates several files. Putting them in a new folder keeps
things organized
(2) Change the file name to “CAR.TXT”
► If you are using the HAAS, the file has to be called “CAR.NC”
b) Hit “Save”
► At this point, it is a good idea to check that the file is actually called what you want it to be.
I have had issues with this in the past. Go to the end of the location under “Output File:”
and make sure it only say CAR.TXT after the last \
3. Click “Execute”
4. The “IMSpost – Runtime Message” box appears. This is where you change the program number. The HAAS
will save the program on its hard drive under this name. It must be four digit number. You can leave it at
“1000”
a) Hit “OK”
5. Hit “OK” again
► If you are using “UofI_HAAS.lib” errors will probably appear. These will have no effect on
the code. It is simply an irrelevant translation error
B. Use Window Explorer to open the “Post” folder
C. You will see six different files. The larger “CAR” text file is your G code.
D. Save this file to a floppy disk and run it according to the instruction on the machine

Appendix A: What is a post processor?
A post processor (PP) is a script code that converts what the tool paths CATIA generates into something the CNC
machine can read. The process occurs in two steps. First, CATIA generates the APTsource code. CATIA uses the PP
words table (in our case IMS_v8.pptable) to translate its code into something for the PP to read (all IMS post processors
use the same word table. This is why both the HAAS and Bridgeport PP use the same word table). This APTsource code
contains every output CATIA pulls form the operation definition. The second thing that happens is the APTsource code
is translated using the PP. The PP filters the APTsource code to only draw out the code that the CNC machine can use.
This means that some of the data defined in the operations are not used. (It is still a good idea to define as much as you
can however.) The PP also puts the data in the syntax that the machine can read. If you compared the code posted for
the HAAS and the Bridgeport, you would find that all the points the same, however there are subtle differences in how
the code is presented. The final product is six different files including the APTsource code and the G code.

Appendix B: Excerpts from Bridgeport Code “CAR.TXT”
:1000
' DATE: TUE JUL 19 2011 11:20:40 '
N1 G40 G45 G8 G72 G30 G75 G17 G90 G0 G96
' PP WORD TABLE:IMS_V8.PPTABLE '
N2 X5. Y5.
N3 Z1.
N4 T1 M6
N5 X.247 Y-.369 S1000
N6 Z.719
N7 G1 G94 Z-.031 F30.
N8 Z-.425
N9 Y0
N10 X0 F10.
N11 Y.411
N12 Y2.3
N13 X.762
…
N520 X.646 Y-.072
N521 X.633 Y-.067
N522 X.625 Y-.064
N523 X.57 Y-.041
N524 X.539 Y-.027
N525 X.514 Y-.013
N526 X.502 Y-.006
N527 X.441 Y-.107
N528 Z-.456 F30.
N529 Z.294
N530 X.393 Y-.466 Z.15
N531 Z-.85
N532 X.584 Y-.004
N533 G2 X.338 Y.293 I.742 J.377 F10.
N534 G1 X.248 Y.727
N535 G2 X.248 Y1.473 I2.038 J1.1
N536 G1 X.338 Y1.907
N537 G2 X.584 Y2.204 I.742 J1.823
N538 G1 X.64 Y2.227
N539 G2 X.829 Y2.265 I.829 J1.77
N540 G1 X1.024
…
N556 X1.896
N557 G2 X1.024 Y-.065 I1.024 J1.937
N558 G1 X.829
N559 G2 X.64 Y-.027 I.829 J.43
N560 G1 X.584 Y-.004
N561 X.393 Y-.466 F30.
N562 Z.15
N563 G0 Z1.
N564 X5. Y5.
N565 T2 M6

N566 X4.169 Y.608 S1000
N567 Z.752
N568 G1 Z-.248 F30.
N569 X3.919
N570 Y1.256 F15.
N571 Y1.592
N572 X3.884 Y1.967 Z-.237
N573 Y.233
N574 X3.875 Y.169 Z-.234
N575 X3.87 Y.139 Z-.236
N576 X3.865 Y.103 Z-.244
…
N2882 Y.067 Z-.398
N2883 Y.064 Z-.439
N2884 Z.561 F30.
N2885 G0 Z1.
N2886 X5. Y5.
N2887 T3 M6
N2888 X2.151 Y1.091 S2000
N2889 Z.6
N2890 G1 Z-.15 F30.
N2891 X2.157 Y1.092 F10.
N2892 X2.193 Y1.1
…
N3846 G3 X2.182 Y.789 I2. J1.1
N3847 G1 X2.186 Y.783
N3848 X2.19 Y.777
N3849 G3 X2.19 Y.777 I2. J1.1 F8.
N3850 G1 Z.325 F30.
N3851 G0 Z1.
N3852 X5. Y5.
N3853 T4 M6
N3854 X2.625 Y1.1 S1000
N3855 Z0
N3856 G1 Z-.15 F20.
N3857 G82 X2.625 Y1.1 Z.25 Q0. F12.
N3858 X1.313
N3859 G80
N3860 G1 Z0 F20.
N3861 G0 Z1.
N3862 X5. Y5.
N3863 T5 M6
N3864 X1.313 Y1.1 S1000
N3865 Z0
N3866 G1 Z-.15 F20.
N3867 G83 X1.313 Y1.1 Z.472 Z.05 F12.
N3868 X2.625
N3869 G80
N3870 G1 Z0 F20.
N3871 M30

Appendix C: Excerpts from HAAS Code “CAR.NC”
%
O1000
( **************************************************** )
( * INTELLIGENT … WWW.IMS-SOFTWARE.COM
*)
( * IMSPOST VERSION : 7.4G
*)
( * IMSPOST VERSION : 7.4G
*)
( * DATE: TUE JUL 19 2011 11:21:02
*)
( ****************************************************)
N10 G20 G90 G40 G17 G94 G00 G49 G80 G98 G64 G54
( PP WORD TABLE:IMS_V8.PPTABLE )
N20 G0 X5. Y5.
N30 Z1.
( TOOL DATA : T1 )
N40 T1 M6
( OPERATION : ROUGHING.1 )
N50 X.247 Y-.369 S1000 M3
N60 G43 Z.719 H1
N70 G1 Z-.031 F30.
N80 Z-.425
N90 Y0
N100 X0 F10.
N110 Y.411
N120 Y2.3
N130 X.762
…
N5200 X.646 Y-.072
N5210 X.633 Y-.067
N5220 X.625 Y-.064
N5230 X.57 Y-.041
N5240 X.539 Y-.027
N5250 X.514 Y-.013
N5260 X.502 Y-.006
N5270 X.441 Y-.107
N5280 Z-.456 F30.
N5290 Z.294
( OPERATION : PROFILE CONTOURING.1 )
N5300 X.393 Y-.466 Z.15
N5310 Z-.85
N5320 X.584 Y-.004
N5330 G2 X.338 Y.293 I.158 J.381 K0 F10.
N5340 G1 X.248 Y.727
N5350 G2 X.209 Y1.1 I1.79 J.373 K0
N5360 X.248 Y1.473 I1.829 J0 K0
N5370 G1 X.338 Y1.907
N5380 G2 X.584 Y2.204 I.404 J-.084 K0
N5390 G1 X.64 Y2.227
N5400 G2 X.829 Y2.265 I.189 J-.457 K0
N5410 G1 X1.024
…
N5590 X1.896
N5600 G2 X1.024 Y-.065 I-.872 J1.802 K0
N5610 G1 X.829
N5620 G2 X.64 Y-.027 I0 J.495 K0
N5630 G1 X.584 Y-.004
N5640 X.393 Y-.466 F30.
N5650 Z.15
N5660 G0 Z1.
N5670 X5. Y5.
( TOOL DATA : T2 5/16 BALL END MILL )
N5680 T2 M6
( OPERATION : SWEEPING.1 )

N5690 X4.169 Y.608 S1000 M3
N5700 G43 Z.752 H2
N5710 G1 Z-.248 F30.
N5720 X3.919
N5730 Y1.256 F15.
N5740 Y1.592
N5750 X3.884 Y1.967 Z-.237
N5760 Y.233
N5770 X3.875 Y.169 Z-.234
N5780 X3.87 Y.139 Z-.236
N5790 X3.865 Y.103 Z-.244
…
N28850 Y.067 Z-.398
N28860 Y.064 Z-.439
N28870 Z.561 F30.
N28880 G0 Z1.
N28890 X5. Y5.
( TOOL DATA : T3 1/8 END MILL )
N28900 T3 M6
( OPERATION : POCKETING.1 )
N28910 X2.151 Y1.091 S2000 M3
N28920 G43 Z.6 H3
N28930 G1 Z-.15 F30.
N28940 X2.157 Y1.092 F10.
N28950 X2.193 Y1.1
…
N38730 X2.182 Y.789 I0 J.36 K0
N38740 G1 X2.186 Y.783
N38750 X2.19 Y.777
N38760 G3 X2.375 Y1.1 I-.19 J.323 K0 F8.
N38770 X2. Y1.475 I-.375 J0 K0
N38780 X1.625 Y1.1 I0 J-.375 K0
N38790 X2. Y.725 I.375 J0 K0
N38800 X2.19 Y.777 I0 J.375 K0
N38810 G1 Z.325 F30.
N38820 G0 Z1.
N38830 X5. Y5.
( TOOL DATA : T4 CENTER DRILL )
N38840 T4 M6
( OPERATION : SPOT DRILLING.1 )
N38850 X2.625 Y1.1 S1000 M3
N38860 G43 Z0 H4
N38870 G1 Z-.15 F20.
N38880 G82 X2.625 Y1.1 Z-.4 R-.15 P0.0 F12.
N38890 X1.313
N38900 G80
N38910 G1 Z0 F20.
N38920 G0 Z1.
N38930 X5. Y5.
( TOOL DATA : T5 DRILL )
N38940 T5 M6
( OPERATION : DRILLING DEEP HOLE.1 )
N38950 X1.313 Y1.1 S1000 M3
N38960 G43 Z0 H5
N38970 G1 Z-.15 F20.
N38980 G83 X1.313 Y1.1 Z-.622 R-.15 Q.05 F12.
N38990 X2.625
N39000 G80
N39010 G1 Z0 F20.
N39020 M30
%

